Skip to main content

Forums / Games / Halo Infinite

PC FPS issues and stutter megathread

OP N4y Young

  1. 1
  2. ...
  3. 4
  4. 5
  5. 6
  6. ...
  7. 7
xevman wrote:
xevman wrote:
5950x
rtx 3090
32gb 3600mhz cl16
playing at 5120x1440

Feels as though adjusting or lowering settings does nothing. I'm always between 90-110fps but the frame rate feels significantly lower than that. Feels jittery as if gsync isnt working.
OK guys just an update, I managed to get the game to run at a very respectable level with consistent performance and no hitching or stuttering by doing the following. Compared to yesterdays experience it feels like a whole different game to me. In game settings are on Ultra with 100% resolution scale because honestly they don't feel like they help with the frame rate or performance in game when I lower them.

Firstly Set your minimum frame rate to 120, set your maximum to whatever your monitors refresh rate is, HOWEVER this must be divisible by 60. So no 144 or 165, set it to 120 in this case, or 240 if you have a 240hz screen. ALSO MAKE SURE VSYNC IS OFF IN GAME LAUNCH IT SET IT TO OFF AND CLOSE THE GAME.

Secondly MAKE SURE that msi afterburner and riva statistics tuner are not running prior to launching the game

Thirdly in Nvidia control panel enable Gsync for both windowed and full screen mode

Finally when you launch the game from steam make sure that you have no windows open on the desktop or in the background have them minimized including Steam (which you can minimise quickly prior to the game launching.

I don't know if its 1 or a combination of all of these things that fixed my performance but going from 90-100fps with stuttering and hitching to a consistent 125-145 with none of that is huge for me.
This fixed the stuttering for the most part for me, thanks!
Are people keeping the minimum FPS value set? I believe turning that on enables Dynamic Resolution scaling.

I've disabled it on mine and not had the stuttering that people have been saying.

My specs are below:

Strider BZ wrote:
Intel 5960X (2014 Haswell E 8 core, 16 thread CPU) OC to 4.5 GHZ
32 GB of Corsair Vengenace 3200MHZ RAM
RTX 3070
Running Windows 11 Release Preview Build 22000.194
Running at High settings
Vsync Disabled
Minimum FPS Turned Off
Maximum FPS Set to 240 via 'Custom'
AnimeZoomy wrote:
My R9 Fury X reports full utilisation while drawing very little power and running cool. the game also runs at 20fps and only loses 2 FPS from changing from maximum to lowest settings. R5 3600 usage is around 80% despite the incredibly low framerate. Completely unplayable on my machine and makes me question how performance and optimisation this dismal can at all be improved before release.
Found a fix https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
CPU : Intel I9 9900K
GPU : AMD Radeon R9 Fury (about a GTX 1070, performance wise)
RAM : 16GB DDR4 3200MHZ
Res: 1080P
Drive: SSD
fps in matches is between 22-25 FPS, setting res scale to 56%(min) gives 3-4 more FPS setting to max (200%) I lose 4-5 FPS .
game has some bottleneck somewhere and I wasn`t able to find it.
unfortunately this performance makes the game unplayable for me.
i5 - 6600k
Radeon R9 380
16GB

With a minimum fps of 29 I get about 26fps on low and 20 on ultra but with no discernible different in graphics.
With no minimum fps I get 23 on low and 15 on ultra but with a clear difference in graphics quality.

If you're comparing between different graphical qualities make sure to turn of minimum fps as it will just downgrade the graphic despite the fact that graphics quality changing requires a restart.
Fix for low FPS on your GPUs here:https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
Sorry for the multiple posts mods I don't know how else to get their attention :(
CPU : Intel I9 9900K
GPU : AMD Radeon R9 Fury (about a GTX 1070, performance wise)
RAM : 16GB DDR4 3200MHZ
Res: 1080P
Drive: SSD
fps in matches is between 22-25 FPS, setting res scale to 56%(min) gives 3-4 more FPS setting to max (200%) I lose 4-5 FPS .
game has some bottleneck somewhere and I wasn`t able to find it.
unfortunately this performance makes the game unplayable for me.
i5 - 6600k
Radeon R9 380
16GB

With a minimum fps of 29 I get about 26fps on low and 20 on ultra but with no discernible different in graphics.
With no minimum fps I get 23 on low and 15 on ultra but with a clear difference in graphics quality.

If you're comparing between different graphical qualities make sure to turn of minimum fps as it will just downgrade the graphic despite the fact that graphics quality changing requires a restart.
Fix for low FPS on your GPUs here:https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
Sorry for the multiple posts mods I don't know how else to get their attention :(
IF THIS WORKS, YOU WILL BE MY FAVOURITE PERSON ON THE ENTIRE GLOBE
CPU: Intel i7-4790K
GPU: MSI RTX 2060 Super
OS: Windows 10

Even on low settings @1080p I can't get the game to run at 60 fps. It constantly hovers between 55 and 58 fps and I can't do anything about it. Turning Vsync on and off, changing min and max fps, turning off other graphics options... nothing helps.

I really hope this is resolved once the game releases.
Luxx615 wrote:
1080p
Powerful 3070
5800x
16gb 3600mhz
I'm getting about 160+ FPS constantly but with the most extreme Mico stutters that are also almost constant. When I do have a window of smoothness the aim with controller feels great compared to last flight but the microstutters are worse than at the beginning of the first flight on good PCs. Also worth mentioning the fact of no full screen which adds delay when playing windowed. I didn't check GPU util or VRAM usage. Updating graphics drivers at this point.
Same problem here:

i7-9700k
RTX 2080 Super
32GB ram (at 3000mhz)
Win 10
1440p, all Graphics on medium

FPS are between 80-120 but it stutters almost all the time. Even if i fix the FPS to 60, it shows me 60FPS constantly but it feels more like 30-40FPS witch additional stuttering.
No really perfomance increase if i set the graphic settings to low.

I hope 343i fix that problem for launch. I see such great PC setups here, but almost everyone has the same problem.
Fix for low FPS on your GPUs here:https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
Sorry for the multiple posts mods I don't know how else to get their attention :(
For Anyone wondering: THIS WORKS. I can't express enough how greatful I am for you telling me about these drivers. The game is playable now and I have hope that I will be able to actually play this when it comes out. Thank you so much, I really appreciate this <3
xevman wrote:
xevman wrote:
5950x
rtx 3090
32gb 3600mhz cl16
playing at 5120x1440

Feels as though adjusting or lowering settings does nothing. I'm always between 90-110fps but the frame rate feels significantly lower than that. Feels jittery as if gsync isnt working.
OK guys just an update, I managed to get the game to run at a very respectable level with consistent performance and no hitching or stuttering by doing the following. Compared to yesterdays experience it feels like a whole different game to me. In game settings are on Ultra with 100% resolution scale because honestly they don't feel like they help with the frame rate or performance in game when I lower them.

Firstly Set your minimum frame rate to 120, set your maximum to whatever your monitors refresh rate is, HOWEVER this must be divisible by 60. So no 144 or 165, set it to 120 in this case, or 240 if you have a 240hz screen. ALSO MAKE SURE VSYNC IS OFF IN GAME LAUNCH IT SET IT TO OFF AND CLOSE THE GAME.

Secondly MAKE SURE that msi afterburner and riva statistics tuner are not running prior to launching the game

Thirdly in Nvidia control panel enable Gsync for both windowed and full screen mode

Finally when you launch the game from steam make sure that you have no windows open on the desktop or in the background have them minimized including Steam (which you can minimise quickly prior to the game launching.

I don't know if its 1 or a combination of all of these things that fixed my performance but going from 90-100fps with stuttering and hitching to a consistent 125-145 with none of that is huge for me.
Yes, ty for the informations, it's way better now, the majority of the stuttering is gone. It's not perfect yet, but way better.
Hey guys!

Some information i can give what helped me for better gameplay:

# Turn off minimum FPS
# At least everything on HIGH if your setup can afford it
# Close MSI Afterburner & Riva before starting Halo Infinite
# Turn off V-Sync

Im now at 100 to 130 FPS constantly. Its still not enough for my 144hz monitor and the graphic doesnt rly look final but its playable now :)

Have a nice one!
AnimeZoomy wrote:
My R9 Fury X reports full utilisation while drawing very little power and running cool. the game also runs at 20fps and only loses 2 FPS from changing from maximum to lowest settings. R5 3600 usage is around 80% despite the incredibly low framerate. Completely unplayable on my machine and makes me question how performance and optimisation this dismal can at all be improved before release.
Found a fix https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
I can confirm this driver work, on 1080P Low, running a stock Fury I get 45-60 FPS and setting min fps to 60 I get a solid 60FPS with OK visuals.
I tried almost everything and nothing seemed to work. The only way I could get any form of stable play is by locking my fps between 30-32. It’s definitely not ideal but at least my gameplay experience is a lot more consistent now than it was before when it was going between 20-50 fps. I would advise this to anyone who is at their wits end and is desperate for any kind of solution.
I've got an RTX 3080 and AMD Ryzen 3700x. With the resolution scaling disabled at 4k I seem to get between 72-85 FPS on average without significant stuttering. Not the best but not the worst. I tabbed out to check out HWinfo since I couldn't use RTSS and noticed that I was getting 97-98% Core load on the GPU so I don't think there's any issues there. I am also using the latest drivers. I would hope that by launch I could get 4k 120fps with this kind of setup.
SombreroGG wrote:
3090 RTX
5950X CPU
32 GB 3800mhz ram
1440p 240hz Omen X
170-190 fps in game

Whilst FPS looks OK on a combination of low/medium settings the input latency is terrible on mouse and keyboard. Frame timing feels like its 10ms+ (can't actually get a number due to lack of Afterburner support)
NO fullscreen exclusive mode seems to be a big issue.
So much for PC support in all their marketing.
I realized that everyone kept fragging me with mouse and keyboard so I switched. Controller is no go for me. I cant stand how clunky it is. It is NOT SMOOTH
AnimeZoomy wrote:
Fix for low FPS on your GPUs here:https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
Sorry for the multiple posts mods I don't know how else to get their attention :(
For Anyone wondering: THIS WORKS. I can't express enough how greatful I am for you telling me about these drivers. The game is playable now and I have hope that I will be able to actually play this when it comes out. Thank you so much, I really appreciate this <3
AnimeZoomy wrote:
My R9 Fury X reports full utilisation while drawing very little power and running cool. the game also runs at 20fps and only loses 2 FPS from changing from maximum to lowest settings. R5 3600 usage is around 80% despite the incredibly low framerate. Completely unplayable on my machine and makes me question how performance and optimisation this dismal can at all be improved before release.
Found a fix https://www.halowaypoint.com/en-us/forums/29568daf8cd14083bd1b70a810bf3581/topics/psa-for-amd-hd-7970-r9-290-390-r9-fury-gpu-users/0466a4ee-3cb1-4323-a6b4-63e0355ab0a5/posts?page=1
I can confirm this driver work, on 1080P Low, running a stock Fury I get 45-60 FPS and setting min fps to 60 I get a solid 60FPS with OK visuals.
Ayyyy, glad to hear it fellas. Mad props to nimez for putting those drivers together
CPU: i7 10700K
GPU: 2080 Super
Ram: 16bg 3200
2560 X 1440, 170hz monitor.

Cannot get over 90 FPS, but that rarely happens. When I start the game, FPS counter says something between 2 and 20. The lag between trying to navigate the menu and that actually happening is about 2 seconds. In game it occasionally gets to 30, but doesn't play as it it is 30: the response time is many seconds off and INCREDIBLY staggered. I have 2 monitors and if I click out of the one I game on, the FPS counter jumps to around 100 and the screen suddenly moves smoothly, but as soon as I click back in, frames drop to sub-10.
Have spent more time in the menu effing around than actually playing (occasionally, it randomly decides to go to about 70FPS and stay there, at which point it is playable but I have no idea what I do or why it suddenly decides to work.)
Same as original post: I realize this is a pre-release build... but release is not very far away. I have seen a lot of stuff online saying "since it is a flight, your computer may not recognize it as a game" or something and that causes it to run incorrectly. I am not sure how much I believe that but really hope it is true. When I can play, it is great. Having a ton of fun, and really looking forward to this game. It'll be very disappointing if this isn't just a bug for the flight and the released game is plagued by these issues.
While it sucks to see so many people having similar issues, I was certain that this was specific to me and something was wrong with my PC.. happy to see I'm not alone, but sad we cannot experience this flight as intended.
JKune4226 wrote:
Hey guys!

Some information i can give what helped me for better gameplay:

# Turn off minimum FPS
# At least everything on HIGH if your setup can afford it
# Close MSI Afterburner & Riva before starting Halo Infinite
# Turn off V-Sync

Im now at 100 to 130 FPS constantly. Its still not enough for my 144hz monitor and the graphic doesnt rly look final but its playable now :)

Have a nice one!
This actually helped a lot, thanks! Afterburner and RTSS were the cause of my low fps. Also, Halo Infinite's V-Sync and minimum/max fps seem to be broken. As soon as I turned everything off, my fps bumped from 55-58 to 70-80. Then I turned on V-Sync and triple-buffering via Nvidia Control Panel to finally get smooth 60 fps. What a chore. But at least it IS manageable.
i7-8700k, 2070 Super, 1440p, high settings
Bazaar and Recharge are 80 to 90 ish fps and feel pretty smooth, while Live Fire somehow performs much worse than the other two, it's always 60 ish, doesn't feel great
N4y Young wrote:
After firing up with excitement on Pc this morning I was greeted with what I can only describe as a monstrosity performance wise.

I play at 1440p and specs are:
5900x - CPU
RTX3080- GPU
32GB 3600Mhz RAM

i tweaked and adjusted all settings to try various configurations. My conclusion is that nearly all combinations yielded very similar results with the standard margin for error in mind. My experience is a frame count of circa 110, static and as soon as anything happens on screen dips to roughly 90 or just below. However what is on screen still doesn’t reflect 90FPS and feels like playing a game at sub 30 on an old console when overloaded. VRAM us wage is 60% (ish) but GPU utilisation rarely passes 50% with CPU utilisation at roughly 25%.

I’ve switched up to the series X which is much less powerful than my rig and the performance and experience is 100x better which is a big concern.

Please use the thread to post your rig and experience and let’s get this magnified ASAP.
I'm having a great experience, staying between 100 and 120 FPS at max graphics...

9700k
3070
16gb RAM 3200mhz

lol
xevman wrote:
xevman wrote:
5950x
rtx 3090
32gb 3600mhz cl16
playing at 5120x1440

Feels as though adjusting or lowering settings does nothing. I'm always between 90-110fps but the frame rate feels significantly lower than that. Feels jittery as if gsync isnt working.
OK guys just an update, I managed to get the game to run at a very respectable level with consistent performance and no hitching or stuttering by doing the following. Compared to yesterdays experience it feels like a whole different game to me. In game settings are on Ultra with 100% resolution scale because honestly they don't feel like they help with the frame rate or performance in game when I lower them.

Firstly Set your minimum frame rate to 120, set your maximum to whatever your monitors refresh rate is, HOWEVER this must be divisible by 60. So no 144 or 165, set it to 120 in this case, or 240 if you have a 240hz screen. ALSO MAKE SURE VSYNC IS OFF IN GAME LAUNCH IT SET IT TO OFF AND CLOSE THE GAME.

Secondly MAKE SURE that msi afterburner and riva statistics tuner are not running prior to launching the game

Thirdly in Nvidia control panel enable Gsync for both windowed and full screen mode

Finally when you launch the game from steam make sure that you have no windows open on the desktop or in the background have them minimized including Steam (which you can minimise quickly prior to the game launching.

I don't know if its 1 or a combination of all of these things that fixed my performance but going from 90-100fps with stuttering and hitching to a consistent 125-145 with none of that is huge for me.
Tried this and got a similar performance boost. What's happening here is the minimum 120 framerate is enabling dynamic resolution, so you get lots more frames but a noticeably softer, blurrier image and breakup on distant details. For some people the extra performance will be worth the drop in image quality, though
64GB RAM,
RTX 3080
5900X
Installed on a SSD (not M.2) that is for games only.1920 x 1080p @ Max I'm getting, according to FPS counter ~180 FPS, but the frame spikes etc are horrible.
Like it feels like below 60 for sure. I tried turning down settings to Low to boost FPS close to 240 in hopes of "brute forcing" through the microstutter, but FPS even dropped to 150 after that. I tried capping my FPS to 120 FPS instead of the 240Hz my screen can and turned on V-Sync and BOY do I tell you that was a mistake.
It totally got the game to it's knees. FPS were 110 - 115, never full and locked 120 which honestly confused me very much and the frame spikes and stuttering felt even worse.
It was like sometimes it plain out missed to renter 0.2 Seconds or so because when I once got headshot killer instead of fully seeing my body fall down, I heard the death sound and what felt like ages later the next frame I saw was my Spartan already on the ground etc.It looks like a very fun game but it feels like it's currently barely playable for me for some reason.
  1. 1
  2. ...
  3. 4
  4. 5
  5. 6
  6. ...
  7. 7