Forums / Support / Halo 4

Mission 4 Ghost Glitch

OP Demonseed1966

At the end of Mission 4: Forerunner, my ghost refuses to boost, thus I am unable to finish the mission. Anyone else eexperiencing this problem? Do I need to uninstall/reinstall?
That Happened To Me Too! Whenever I Boosted All I Could See Was The Ground, Therefore I Was Blind Too. Really Really Sucked Because I Was On Legendary With Mythic On, realy hard being blind... lol
For me the most annoying point in the game. I'm disabled and therefore only have 1 hand on the controls and thereby having to boost and steer at the same time is just impossible for me. It's a really poorly thought out section of the game. In all the other driving missions in the series you don't need to boost to get through. As long as you continue to move forward along the path without stopping you can generally make it but not here. The boost is still there if you want it but it's not a necessity. It's a poorly thought out section which I pretty much skipped on the MCC. I like this series and Halo 4 has still got a great story but the level designs in 4 could have done with more work. The only other mission that comes close is Halo 1's finale but I think that can be fixed with an addition of an extra checkpoint at the section you meet up with Foe Hammer
nah just keep trying you'll get it :) worked for me
I've also bumped into this glitch. It's the reason why halo 4 remains the only game in the series I haven't finished. I've replayed the level several times to try to fix it. For whatever reason the ghost never boosts. I press LT for a boost and I get slower than normal ghost speeds. I've tried every other ghost there, gone back to previous I checkpoints, replayed the entire mission 4 times and tried every way I could of completing the level without the all important boost. This is one frustrating bug. Has anyone got a fix?
Its not actually a glitch, it happened to me but its actually your controller. Its a screw that has messed around with lt and is not letting it register. Either use a seperate controller or get it looked at. But thats just what happened to me.
Get your remote looked at or something.
Odd, this has never happened to me.
Just figured out. If you are using an elite controller you have to have the full trigger range. The short trigger apparently doesn't register correctly for that peticulare part.
I have never had this glitch
So I have an elite controller and wonder will I never be able to get across the canyon in the ghost? Ive tried it sooooo many times and always crash into rock wall.
So I have an elite controller and wonder will I never be able to get across the canyon in the ghost? Ive tried it sooooo many times and always crash into rock wall.
Just watch a video on youtube how to do the run. Then repeat what you saw.
Just played it with an Xbox One elite controller. There are two switches on the back - they affect the trigger range. Make absolutely sure that the switches are in the UPPER position (in this case, closer to the triggers). That will give you full range on the triggers and the ability to boost the ghost and allow the jump to be made.
I would help you friend, but it is not something that happened to me, I hope your problem has or has had a solution
Just figured out. If you are using an elite controller you have to have the full trigger range. The short trigger apparently doesn't register correctly for that peticulare part.
I know this is an ancient thread, but just wanted to say a huge thanks for this. First time playing through and I was about to quit or skip the level.
Just got around to this and getting the ghost glitch, any way of doing it without buying a new controller as it works fine on every other game I have.
Quote:
Quote:
Quote:
If using the Elite controller i ended up taking the triggers off and just using LT. Make sure the switches in the back are in the top position.
At the end of Mission 4: Forerunner, my ghost refuses to boost, thus I am unable to finish the mission. Anyone else eexperiencing this problem? Do I need to uninstall/reinstall?
This has also been happening to me, I am trying to complete halo 4 on legendary so I can get the legend achievement but this glitch is not letting me boost so I can't complete the mission.
Just figured out. If you are using an elite controller you have to have the full trigger range. The short trigger apparently doesn't register correctly for that peticulare part.
Dude thinks a lot for saying that it would have took me weeks to figure out that, really appreciate it.