Forums / Games / Halo Wars Series

[Locked] Multiplayer Beta – Official Bug Report Thread

OP Forum Team

  1. 1
  2. ...
  3. 41
  4. 42
  5. 43
  6. 44
  7. 45
  8. ...
  9. 99
Sorry that I keep adding these instead of just one comment, but I keep forgetting about them and finding new ones. Whenever you recycle a base, your leader will say that the enemy has destroyed that building, even though it was recycled, not attacked and destroyed.
Smosher74 wrote:
My game constantly crashes right before the tutorial turns off and I've tried everything to get it working. Also the load times are unbearable and I've had many disconnection issues with other players. Also the limit cap is extremely small
Okay, I figured out a way to get past this freeze while trying to recreate the error to help my friend troubleshoot it, because I didn't run into the error until I purposely tried to recreate it.
  1. Title Screen: Press X instead of the menu button to see your profile and sign in.
  2. Immediately begin pressing the B Button to skip the tutorial vid that causes many freezes.
  3. Screen will freak out a bit and you may see some game code where it would normally say "press b to skip" but it will disappear quickly.
  4. The "Find Match" screen should appear, with you being able to pick the "Halo Wars 2 Beta" Playlist
Hope this works for you, and have fun playing the Beta!
Hey. Every time y press the start buttom it freezes.

Anyone experiencing with this ?
With game installed on external hard drive I could not get past the main menu without the game freezing every time I pressed the list button. I tried using the spam the B button suggestion from the Reddit thread but that did not help.

After moving the game to the internal hard drive, doing 3 hard resets of the game, and finally letting the game idle at the menu for about 2 minutes I was able to watch the entire intro tutorial and get to the matchmaking menu.

-Steel Cortana
I was having the same problems with crashing multiple times. I finally tried to just let it sit and pan through the set camera angles a couple times when its just showing the Spartan, tank and hogs. Then I pressed start and it worked finally. Maybe it just needs a minute or two to warm up once it gets to the title screen.
Well it still freezes at connecting to halo wars 2
Loving the Beta so far. The only problem I keep having is that it crashes mid game.
I haven't even been able to play a game. Furthest I got was the first menu and that was ~10 tries ago.
Gelophia wrote:
Hey. Every time y press the start buttom it freezes.
Anyone experiencing with this ?
Yea it's a pretty well known glitch. Here's a vid how you can get around it

https://www.youtube.com/watch?v=NHalMh0IrqA
killer6785 wrote:
I was having the same problems with crashing multiple times. I finally tried to just let it sit and pan through the set camera angles a couple times when its just showing the Spartan, tank and hogs. Then I pressed start and it worked finally. Maybe it just needs a minute or two to warm up once it gets to the title screen.
Well it still freezes at connecting to halo wars 2
Not if you let the opening screen stay up for about 30 seconds like Killer6785 described and then spam 'B' after you hit 'Enter'

This vid i found will explain it, https://www.youtube.com/watch?v=NHalMh0IrqA
I give "Skip" to the intro and locks, have to reboot and see everything.
The game get crashed 3 time when its loading the main menu and i have to close and open the game until it can load the full start menu
When I downloaded the game, I started it up immediately and the first thing i noticed was that the language was in Spanish for some reason. I am from the Netherlands. I have most of my games in English and just a few in Dutch, so I do not understand why it is in Spanish. Then I tried to play the game anyway(My spanish is bad, but I can understand a few things) and it kept freezing everytime I tried to load the game or whenever the main menu came up. With this going on, I cannot test the Beta out like it should be. I know it is a Beta and a lot of things are still being worked on, but not being able to play the Beta is different story. I would love to have this fixed, both the language and the barricade that's blocking me from playing the Beta, so that I can try to enjoy the Beta and give my feedback on the gameplay.
1st time I downloaded the beta, it took about 3 hours to load and when it was finished, I tried to play but couldn't get past the "Welcome to the Beta" and press "A" page. I tried fixing this by going back to the dashboard and quit the game to try it again. Same thing. Tried to wait 4 minutes before pressing A but still wouldn't work. I repeated this process till I decided to uninstall and reinstall it around 3 am last night. Woke up and did the whole thing over again, still couldn't get past the "Welcome to the Beta" page. than did a hard reset on my console several times until this afternoon where I decided to uninstall and reinstall the game AGAIN. I am still stuck on the the Welcome to the Beta page. How is it they haven't been able to fix the simple problem?
I can't help but feel this was rushed to Beta due to E3. I have played many games in beta, but this really feels more like it's Alpha at best. Yesterday I could get into a game by mashing the b button to skip tutorial, but today is constantly freezing on the title screen. I was only to play one game so far, the other two games I got into Yesterday crashed in the middle.
can't wait to play the beta!
TO ANYBODY STILL GETTING CRASHES/FREEZES IN THE MAIN MENU WATCH THIS VIDEO TO FIX IT.

https://www.youtube.com/watch?v=NHalMh0IrqA
Downloaded my copy the game froze and a message poped up that it will restart and update which it did not uplate, it just restarted during the loading of game play. There's little twitches in the menu where the screen turns blue at first.
Game crashes consistently at the tutorial video when skipped, as well as occasionally at the "start" menu.
Losing screen disconnects:
"The game kicked me in a match right before it closed out for a victory, showed a defeat screen that also clearly showed me on the winning team, and said defeat simultaneously.EDIT: The above glitch happened again.Captains commands are super laggy, if used immediatley after the captains commands upgrades, have had it freeze there.Frame rate drop in full infantry fights- not surprising but strategically speaking I couldnt always tell fast enough that commander techs were being used against me, or be able to drop my own fast enough.Probably not a bug, but at the start of a game "waiting for players had a few noteworthy things:
-could last minutes or skip completely
-showed in the background(where the waiting for players screen is the overlay) it showed us the last screen we would see of the previous game, whereas in games you complete sometimes you can see the scores attempt to reset, I assume as a way to mask that.Have had occasions on point C where I could see enemy infantry through the fog of war as shadows as they approached it.More of a complaint: the two or three disconnects I had, having played all placement matches with a same friend, led me to place significantly lower than he did, him having played all 10 0oacement matches as well. In cases of the disconnects, we knew they were server side because we remained in amy xbox live chat throughout all of them.

Edit: a troubleshooting option for those needing to restart the gsme when it won't connect- pressing select, then watching the tutorial video, will crash you out of the game :^)
I would like much that last game in The Hague more diversity of Heads
-Beta appears in store as "legdrop" and sometimes doesn't apears the download option
-Game crashes before, during and after the main screen, sometimes the screen is totally black, but most of the times the game freezes in the tutorial video
-In spanish version, when game starts and waits other players to conect, appears a weird text "wááìting fôôr plááyèrs", instead of "waiting for players"
-The Cutter's description in spanish version has mistakes
-Game crashes very frecuently
-Sometimes MAC animation bugs and "red ray" and explosion animation doesn't appear, it just makes the sound and makes the damage to the enemies, this also happens with the UNSC Artillery
-Delay when purchasing leader´s abilities and buying buildings, it doesn's confirm the purchase right after pressing "A" button
-While "Waiting for players" text appears, in the background screen appears the last location and points of the last game you've played
-In the loading screen's minimap, the free bases slots doesn't appears, only the A,B, C, D, E and energy points, as well as your main bases

This is all what I've seen in my first day, hope help with this.
  1. 1
  2. ...
  3. 41
  4. 42
  5. 43
  6. 44
  7. 45
  8. ...
  9. 99