Forums / Support / Halo Channel

Intermittent Wrong Language

OP EWOKofDESTINY

  1. 1
  2. ...
  3. ...
  4. 2
When watching videos on the Halo Channel on my Windows 8.1 laptop, some videos will be in another language (not english). When I click on audio options, it says the audio language is english, and doesn't even have a choice for other languages. This happened while watching Halo:2A cinematics.
Is there a specific video that this occurs in, or is it all of the H2A content? Trying to get an idea of where to start on troubleshooting this one!
Also, which version of Halo Channel are you using? To find it, in Windows, open the Charms menu (Mouse to the edge of the screen to open the sidebar *OR* Windows Key+C (Win-C) to open the sidebar charm menu

Select Settings
Select About
The version should be posted in that screen.
Version 1.0.0.12

It happened with the video Another Day at the Beach, and Juggernaut. It is still happening with Juggernaut. I'll let you know if any other videos do this.
The Oracle,Edification, Helljumpers, one way ticket, Shooting gallery,That Old familiar feeling, inside job, fight club, once again with feeling, my size 24 hoof, backseat driver, delusions and grandeur, post credits teaser.
Version 1.0.0.12

It happened with the video Another Day at the Beach, and Juggernaut. It is still happening with Juggernaut. I'll let you know if any other videos do this.
Thank you for that... I am able to reproduce this! I believe the language is defaulting to Korean, but there seems to be a work-around, at least it worked for me:
During video playback, open up Closed Caption or Subtitle options, and select the language you wish to swap to. I actually selected ES (Spanish) then selected EN (English) and let the video complete.

Then, from the end screen, I clicked on the mini-video window to Replay, and it played back in English. It worked for me at that point... Will enter a defect on this issue though, as it should not have defaulted to Korean.

Incidentally, when I went to Another Day at the Beach, post Juggernaut, it had remained in English for me. Hoping this works for you as well.
Side Note: When I launched The Oracle, it started with Korean, and while it didn't offer any other languages, I 'selected' EN, then restarted the video and had success at listening to english on the second play.
Thank you so much for looking into this for me. I appreciate you finding the temporary work-around as well. I had stumbled across this work-around twice but I couldn't remember exactly what to do to reproduce it, now I know. Good luck finding the solution to this problem and have a great week.
I'm having the same issue on xbox one using the halo channel app. It also occurs on the nightfall videos (though I believe those are playing in Russian, where as Halo 2 movies were playing in Korean
I'm having the same issue on xbox one using the halo channel app. It also occurs on the nightfall videos (though I believe those are playing in Russian, where as Halo 2 movies were playing in Korean
Is it occurring on all Nightfall, or just a select few?

Edit: As a follow up, I am unable to reproduce this issue with any of the Nightfall videos. :( They all defaulted to English for me, and when I did change language, they all changed within seconds)
Also: the supported languages are:
English
Spanish (Latin American)
Spanish (Spanish)
French
German
Italian
Portuguese

Please attempt changing to English (Or language of your choice) during playback by selecting A to open transport controls, then navigate to the right to either the CC or Subtitle page, and selecting the language you wish to hear. When done during video playback, it should change within 6-10 seconds, although we are aware that short videos may have already buffered all of the content, and would require a restart to update.
I am watching H2 cinematics and I believe it is switching to Japanese. It has happened on multiple videos. I've found that turning on the captioning gets it to switch back.
I am watching H2 cinematics and I believe it is switching to Japanese. It has happened on multiple videos. I've found that turning on the captioning gets it to switch back.
Thanks... and verified. We have identified a few cases where we swap to Korean, and are busily working on fixing this! Appreciate the specific feedback, as it cuts my investigate time down, allowing me to get data to the devs faster!
I have the same issue. It plays in Russian, and japanese sometimes, AND ON COMPLETELY RANDOM VIDEOS!!! Spartan ops, ONI eyes, anything!!!
We are testing an update that will correct this issue... Just so folks know.
We are testing an update that will correct this issue... Just so folks know.
Thanks for keeping us informed. :)
So I just updated halo channel on my Xbox one, (Haven't played in a while) and I went to go view the Spartan ops videos and they're all playing in Russian. It won't allow me to switch the language once the video is playing. Looking at the dates of these comments it would appear there should have been a fix by now...
I'm afraid it looks like this issue hasn't been fully resolved. I just encountered Russian when trying to play Spartan Ops videos.
OO7 JB wrote:
I'm afraid it looks like this issue hasn't been fully resolved. I just encountered Russian when trying to play Spartan Ops videos.
Yup, this is still happening for me with the Halo 2 Cinematics.
Straight after reading this my halo channels language fixed itself without me needing to do anything also halo nightfall keeps on stopping and giving me the message that I can't watch it at the time I think halo channel has a few bugs needed to fix it
H2A cinematics playing in Japanese and Korean. On XB1.

Even resetting the language and subtitle options won't correct it. Open guide and restart vid, occasionally works. When autoplay opens next vid, wrong language again.
Still happening here. Xbox One vid playback, both terminals from Halo 2 Anniv. and Halo 4 Ops videos. I've heard both Russian and Japanese. No choice of other languages. Restarting Xbox did not fix.
  1. 1
  2. ...
  3. ...
  4. 2