Skip to main content

Forums / Support / Halo: The Master Chief Collection Support

Alt+Tab causing game to disappear, not crash

OP eXeFTW

  1. 1
  2. ...
  3. 2
  4. 3
  5. 4
  6. ...
  7. 5
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
you fix works for me I alt tabbed out to write this and back into halo again and it works perfect Thank you very much
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
you fix works for me I alt tabbed out to write this and back into halo again and it works perfect Thank you very much
doesnt for me my settings are already like this
why are they asking us to send in tickets if it's clearly a wider issue? wheres a ticket gonna get us?? its happened every time ive tried playing a game these last few days, the games been unplayable and due to it not being an actual crash im worried about getting a bad rep
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
Thank you so much for this! I tried this fix out and it worked! I'm not sure if that's going to be the case for other people but I can confirm that this fix can work.
This happened to me 2 times in the last 3 weeks
Happens here too
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
Fixed my issue, thanks!
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
I want to report I also experienced the issue and the fix above worked. To anyone reading, make sure you change FROM "only the desktop I'm using" TO "all desktops".

I'm used to skimming technical stuff and I at first misread it as the opposite, so double check if it doesn't seem to work. It should now be set to "all desktops."

Why is halo running in its own virtual desktop, if that's what this means? idk, it's kind of nutty
Same thing happening to me.
If your in task manager, look on the 'details' tab you'll see it running.
it cant restore.
Clarke 311 wrote:
IanCasll wrote:
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
This works in windows 10, weird it does that, thanks man
Id like to thank this user for a valid fix and also report I encountered the issue in MCC Halo CE Anniversary while alt tabbing.
Seems to be working now after doing this.
Thanks for the suggestion
Me too, a number of times now. I forgot to mention it in my Insider feedback. Perhaps someone can look at this issue. It's a one in a hundred problem I think. Requires TM End Task or even SignOut/Reboot.
Fix above (All Desktops in Virtual Desktops - Search in "Settings"). Hopefully sorts it.
Good work Runstarr :) Thanks
Also happening to me now. Amazing how many issues the Microsoft Store version of the game has. I'm sure this would never, ever happen with the steam version, let alone a bunch of other issues I've had with MCC. Really sad how their own platform on their own OS runs the game worse than Steam.
Same issue happened to me last night. Tried ALT+ENTER to make it windowed and that didn't work. Then tried ALT+TAB and the game disappeared but I could still hear audio but could not find MCC running in my task bar nor my task manager..
I was able to fix this by:
  • Hit the Windows Key
  • Type Multitasking Settings, Hit Enter
  • Under Virtual Desktops, change both settings to All Desktops
Then, the Halo MCC icon appeared in my taskbar. Thank goodness.
Also happening to me now. Amazing how many issues the Microsoft Store version of the game has. I'm sure this would never, ever happen with the steam version, let alone a bunch of other issues I've had with MCC. Really sad how their own platform on their own OS runs the game worse than Steam.
I use the Steam version and ever since the Halo 4 update this happens nearly every single time I alt+tab out of the game. So definitely not just an MS Store problem.
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
Same issue, this isnt a fix that worked as settings are already turned on. This started doing this last night and now it's annoying tf out of me as I cant change to discord tab. Please fix...
Had this happen to both myself and a friend of mine; game disappears effectively disappears, has to be closed via task manager
Runstarr wrote:
Hello,

Had this issue as well and the following fixed it:

Search with cortana (in windows) for "multitasking settings" and under "Virtual Desktops" change both options to "All desktops" from "Only the desktop I'm using".

Good luck.
This works.
I had this issue in halo mcc AND other games. This isn't a halo bug. This is a windows 10 bug.
Thank you, Runstarr!
Same issue here.
Reposting this from another thread: it seems like it could be a possible driver issue

I fixed this by going into NVIDIA Control Panel>Adjust Desktop Size And Position>Scaling and changing it to No Scaling.I have no idea why this works, but it did.
Reposting this from another thread: it seems like it could be a possible driver issue

I fixed this by going into NVIDIA Control Panel>Adjust Desktop Size And Position>Scaling and changing it to No Scaling.I have no idea why this works, but it did.
This seems to have completely fixed the issue for me, thanks!
  1. 1
  2. ...
  3. 2
  4. 3
  5. 4
  6. ...
  7. 5