1. 1
  2. ...
  3. ...
  4. 2
Failed to connect. Ive found at least a few hundred games and only have actually connected to 1 firefight and 1 ffa match. I dont understand how putting back the dedicated servers made the game almost completely unplayable like before. Its actually worse now because i cant even find another player while im searching for reach/h3 when we can guess those are the most populated

edit: its also like this on pc where i actually found the games. Havent gotten anything while on xbox
Man my friend and I were so ready... brings back memories from MCC launch. I really hope this will get fixed very very soon. Havent been able to play one social game on any Halo in MCC..
I think the servers are crowded
I think the servers are crowded
they are not. this released on a tuesday while most people are still at work or school
I played early today and didn't have issues. Sorry it's happening to you but now's the time everyone is getting off work and school.
This update feels like MCC release day
I got the same issue. Have been searching for an hour, but have failed to connect to any games, even though it says ‘connecting session’ every ten seconds.

I am not disappointed, I actually find it rather amusing that it doesn’t work. I mean… of course it doesn’t work it is MCC after all. Anyway, I am glad they didn’t rush the release so it wasn’t was ready on launch.
Yep also having this issue it quickly says failed to connect then repeats the process sighs
Try turning off relay servers if you have them selected. Seems to help some people.
Try turning off relay servers if you have them selected. Seems to help some people.
^^^
Follow what he said. Turned it off, and that solved the issue of not connecting to games.
Yes the relay thing works! Have fun, everyone!
Try turning off relay servers if you have them selected. Seems to help some people.
^^^
Follow what he said. Turned it off, and that solved the issue of not connecting to games.
This doesn't do -Yoink-.
Try turning off relay servers if you have them selected. Seems to help some people.
^^^
Follow what he said. Turned it off, and that solved the issue of not connecting to games.
This doesn't do -Yoink-.
Same. Tried many times
MdAuTnTn wrote:
Try turning off relay servers if you have them selected. Seems to help some people.
^^^
Follow what he said. Turned it off, and that solved the issue of not connecting to games.
This doesn't do -Yoink-.
Same. Tried many times
As I said, it seems to work for some people.

Taking a look around, this is the only suggestion I’ve come across from the folks at 343. Not sure why they’re largely absent from social media and the forums today. Would be helpful if they’d address some of these concerns promptly and directly.
I’m having a similar issue. With all titles checked under the social playlist I cannot get into a game. I’ve even changed it to 4v4 but still having the issue. I see “Connecting Session” to “Players Found” and back to “Connecting Session” however the lobby never populates.

Hoping 343 resolves it sometime this week.
For me I had to make sure my steam was online. I always have my friends list set to off so I’m not bothered. Hope this helps.
Experiencing the same issue during a match. I'm playing and players lag out. I'm from Europe and have relays off. I've also tried port forwarding but that doesn't to help.

My other two mates don't have the same issue as I do, eventhough we all use the same ISP. Note, I'm also on a wired connection - fiber optic 100 up and down. And no, this doesn't happen in any other game I play. Neither did it ever happen when I play Halo 3 & Halo Reach during its release on the XBOX 360.
My friend had the same issue and found it it’s because her internet had a shield block on it so all they had to do was turn it off and then they could play
Tecapan101 wrote:
My friend had the same issue and found it it’s because her internet had a shield block on it so all they had to do was turn it off and then they could play
what u mean had a shield block? how to turn it off?
  1. 1
  2. ...
  3. ...
  4. 2