Skip to main content

Forums / Support / Halo: The Master Chief Collection Support

Halo CEA PC Co-Op CONNECTION INTERRUPTED

OP YuseSale

  1. 1
  2. ...
  3. 2
  4. ...
  5. 3
For anyone still having issues. Me and my friend both turned Windows 'Game Mode' on and it worked.
So me and a friend were both having the issue, but we had game mode enabled already without luck. The weird thing is all the levels in Halo:CEA up until The Maw worked fine. But then the "Connection Interrupted" issue on The Maw.

We tried everything to no avail:
  • Enabling UPNP
  • Port Forwarding Manually
  • Enabling / Disabling relays
  • Disabling all irrelevant background processes
  • Disabling Game Mode
  • Pre-caching the game in Singleplayer
  • Throttling potentially faster HDD on one player's system and CPIU with a benchmark test (lol)
Although... Player A had no problems with playing "The Maw" with other players (We'll call "Player C"), so we knew something was up with "Player B". Finally, we got the following to work:
  • Player B moved installation to a faster hard-drive (C drive)
  • Player B opened a game with Player C to "pre-cache" the mission files(?)
  • Player B left game with Player C
  • Player A invited Player B back
  • Game launched without issue.
TLDR: Player B potentially had a slower hard drive than Player A. Player B moved games to a faster alternative harddrive.
It seems that the disconnect issue for The Maw has persisted into Halo 2A for my friend and I. If the above post is really the solution, that's ridiculous, but I appreciate the information provided.
I am also having the same issue with Halo 2 Anniversary on PC.
Same issue here on H2A for PC through Steam
Having the same issue here with Halo 2 on PC through Steam
I am also having this problem with Halo 2 (Steam-MS Store Coop) - Reach and Halo : CE ran fine with absolutely no such problems. We were able to play the first mission after a few tries but now we just can't get it to work anymore.
I was able to play Halo CE and Reach just fine in online Co-OP (though admittedly the CE Co-Op was EXTREMELY laggy). But as others have mentioned we can't get it to work for Halo 2A. I don't have a HDD and he doesn't have an SSD so we can't install it on the same type of drive. I really hope 343 fixes this.
I just wish we could get some sort of official response to this. I don't think I've ever, in any game, had an issue that persisted for this long without any acknowledgement from the devs.
I have tried everything I even bought an SSD, but the problem still hasn't been resolved.
Good luck getting this issue fixed. Seems like it's straight up being ignored. Even my customer support cases remain unanswered.
Hello,

For myself, had issues with only Halo CE and Halo 2. Was trying to play it with my friend, we had previously already completed Halo Reach. We were able to play that with no problems. But with Halo CE and Halo 2, we would load in but it would take awhile and then it would give an error saying "Connection Interrupted". Tried multiple solutions and tried speaking with support, to no avail. Eventually found that it was due to the fact that I put Halo on my external drive, I am on a laptop, and due to a longer than normal load time it timed out our game connection. Moved it to the internal drive and it works now.

Probably won't be the solution for everyone but hope it helps. :)
is anyone else still getting this error on halo 3? like it keeps happening every level, i have restarted the game, reinstalled btw i am on pc
I have been experiencing this problem on halo3 on PC EVEN WHEN I AM PLAYING ALONE.
curiously, this only happens in the palylist ,when i try to play the same level in the mission setcor , everything is fine.
but last week I was playing with my friends just fine, just can't see why anything could go wrong.
Ya we've had trouble on 2 levels in halo 2 and 2 in halo 3 now so frustrating
Its been 5 months and this is still an issue?
Still having issues with Co-op, me and my friend went through LITERALLY every single "fix" on the internet and it still doesn't work...
Hello i am having the same issue "connection interrupted" when my friend and i try to play The Maw and complete the CE campaign. i was able to play through the entire Halo Reach campaign and never encountered this issue but now it is a constant struggle i have not been able to play Halo since this issue popped up can anyone help at all ?
I submitted a ticket a month ago about the same issue and they still haven't responded. I highly doubt they will ever fix this problem, unfortunately.
If they fix it, it'll probably be after 4 is released :(
  1. 1
  2. ...
  3. 2
  4. ...
  5. 3