Skip to main content

Forums / Support / Halo: The Master Chief Collection Support


OP Marcus Seth

  1. 1
  2. ...
  3. ...
  4. 2
I've recently completed Halo Reach MCC on Legendary difficulty solo. However the missions."The Package" and "Exodus" still remain incomplete. I decided to play the package again on legendary difficulty, completed it, got to the end of the cutscene, still no achievement.

Really hope this gets fixed soon, honestly quite annoyed that I replayed the mission only to get nothing out of it.
Whole mission was played in one shot without stopping and barely any deaths. Also if I did not complete the mission, how would it be even possible for me to progress to the next few missions and complete them solo?
I'm having the same issue - I've completed every mission on Legendary, solo, and the only mission that refuses to complete is The Package. Everything else is marked "Complete on Solo Legendary", The Package is stuck at Normal.

EDIT: Okay, after 3 days and 4-5 attempts of trying to get the Legendary completion, it worked just now.
I'm having this issue with the par time on Tip of the spear. I did get the achievements for completing all missions under par but mission 5 isn't unlocking for me.
For some reason Oni:Sword base legendary progress didn't unlock for me yet when I replayed the mission on easy it said my highest completion level was easy...
Lucky for you guys. I have played Long Night of Solacd twice now and it hasn't tracked. I hate this mission the most of any games, and it has been such a slog. Also imagine my annoyance when I try to get the legendary ending where I can see chief only for it to end and I realize this once crappy mission didn't register.
Same here, Nightfall on legendary didn't pop on completion.
Same. I've had this happen on three different missions. I'm going through for the solo legendary completion achievement. Just spent an hour on The Pillar of Autumn for it to not count. Love it.
Im having the exact same issue. Pillar of Autum completed on legendary solo 3 times now, still not registered, gettin a tad raging with it now.
Same thing on the Package. It doesn't register the completion. I got the achievement for not damaging the tank but no achievement for ending the mission.

Any fix?
Same issue here, I completed “The Pillar of Autumn” mission 3 times on legendary and it still says I haven’t completed it yet.

It really pisses me off because I want the achievement, I also have issues with other achievements, “Two corpses with one grave” is another
I had to complete Sword Base 3 times before it showed as complete. Currently the Package and PoA are not showing as complete on Legendary Solo. Am going to wait until an official fix or word there of is made. Definitely frustrating.
I've tried Two Corpses in one Grave about a 100 times and it will NEVER unlock for me. I hope they will fix that soon.
Finished The Package for the 3rd time after reinstalling and it worked.

Right after I tried PoA for a second time and it didn't unluck. Sucks... Hope they fix it
I've had this happen to me on 4 different missions, and of course I didn't notice until I finished the pillar of autumn that some of my other missions didn't unlock properly. I am beyond mad right now!
What’s odd is the game recognizes I’ve beaten Winter Contingency on Legendary, but it won’t give me the achievements for completing that or on hard. I guess it’s just a matter of running the missions over till i get it?
This post has been edited by a moderator. Please do not post comments that are discriminatory in nature.
*Original post. Click at your own discretion.
MCC: Reach - PC

I just completed the the "Classic Completion" 3 times, once yesterday night and twice today, as well as "This is Not the Greatest Lab in the World..." once today. Both achievements fails to unlock on Steam and in the Career and Options -> Reach Achievements shows they are still locked within the game. =(

I dunno what else to do. I tried restarting my comp and that doesn't fix it. I had an issue yesterday (like around 11:30pm PST) where I would complete an achievement (Did You Major in Marine Bio...), quit and re-enter the game. Then upon re-entering the game granted that achievement. But after that, all achievements stopped working for me.
3 of our achievements haven't popped (steam or in game).
* Tank Beats Everything
* Fly, You Fools!
* This is Not the Greatest Lab in the World...
* No Picnic
I haven't had issues with achievements popping in game (tip of the spear par time pops in game but is bugged with steam (known issue?))

My guess is some service is down currently? Playing with friends it doesn't pop, and playing solo it doesn't pop (after restarting the game twice)

I guess I just won't play today
I am on the Pillar Of Autumn but the achievement hasn't made any progress like I haven't done it. I am doing it with 2 skulls, Grunt Brithday Party and IWHBYD and if that is why it hasn't progressed then that makes no sense because it makes no in game advantage and there hasn't been 1 special dialogue so I don't understand why it hasn't worked.
Just finished The Pillar of Autumn under par on Legendary but it has not registered the completion at all. No achievements, even the "Difficulty completed" only shows Heroic. Infuriating. Something should be done to fix this ASAP.
  1. 1
  2. ...
  3. ...
  4. 2