Forums / Support / Halo: The Master Chief Collection Support

odd issue with loading into matchmaking games


I have briefly explained this to Postums via Discord DMs.
Since around the first or second week of Jauary, I have not been able to load into matchmade games. I can search and find matches, but get to the map loading screen and it doesn't load, kicks me to menu, and says connection to game session was interrupted. This happens whether I am solo or with a party. I have no problem at all playing online customs, just cant load into matchmaking 99% or the time.
I will list every fix i have tried, but will first say i now have it to where i can get into 2v2 matches maybe 50% of the times i search, and have been able to get the odd 4v4 like once every hundred attempts.
It is NOT my internet. Multiple speed tests, and multiple checks under network settings on the Xbox dashboard show my connection is very good, Nat is open, also MCC is the only game i have any problems with at all. Again, i had no problems before this January, and had not changed anything with my setup that could have led to the issues.
I have tried the following methods to attempt to resolve my problem and have had barely any success:
Uninstalled/ reinstalled my digital MCC three different times
Repeatedly cleared my cache
Changed my DNS to the Microsoft DNS (think that was what it was, cant remember, this reset to my default after factory reset)
Bought the game on disk, uninstalled my digital, cleared cache, installed off disk. When that didnt work, i returned the disk and reinstalled my digital copy.
Yesterday I finally resorted to factory reset of my console and installed the game again.

After al this, I can still only play customs online, 2v2's sometimes, and cant get into 8v8 or 4v4 matchmaking games. This is rather frustrating, as I am in the BTB tourney March 2, and would like to be able to get some time in matchmaking, since i havent been able to actually play 8v8 since early January outside of customs and my full team is rarely on all at the same time to be able to run customs. On top of that, I have been playing Halo since CE on the original Xbox, Halo is the only reason I never jumped to PS4. I would really appreciate any assistance or recomendations that I haven't tried.
Thank you
I have the exact same issue, and have had this issue since the big August update last year. Prior to that update, I was able to access matchmaking just fine -- I'm thinking probably because many games at that point weren't being hosted on servers, but instead relied on P2P connection. I can play custom games with friends just fine, so I think this has to do with the servers. Any other xbox game I have no issue with matchmaking (e.g. Rocket League), this is MCC specific. I have recorded a video of the issue below -- skip to 1:06 to skip the main menu loading and watch from there:

As you see, I check my connection to the servers and refresh a few times -- the first few times looks like everything is good (though the last refresh you see some "Unavailable" servers creeping up the list). I get into matchmaking fast, map menu loads, kicks me out. Go and check the servers and boom, all of them are unavailable, and I can't get back into matchmaking. After I hard reset the xbox, this cycle just repeats. Rancid, does this match your issue? Have you tried looking at the server connection status like I did and can you verify we are having the same issue?

My NAT is open, my IP for my xbox has been changed to static, all the ports that have been listed as needing forwarded have been forwarded (, and I have uninstalled and reinstalled the game multiple times to the internal hard drive.

Other mentions of this issue that I have seen mentioned in the past:
3) -- I tried the solution mentioned by Evil Rich 89, but it did not fix the issue
4) -- back then I was able to get games in H2A somehow -- I can't anymore.

I hope that this issue can be resolved somehow, but am pretty deflated since I've had this issue since August. Maybe there are additional ports that should be open beyond those recommended at the link above? Any guidance would be appreciated.
I'd like to see a response from 343 on this. Can't even play a game I paid for because of this issue.
Zyphex, that is literally the exact same issue. 100% exact same. Except for me it started around the first or second week of January this year. Was fine until then. I have been speaking with Postums from 343 via Discord DM and he seemed as though he has never heard of this issue before. I feel better knowing I am not the only one dealing with this. I was starting to think there was an issue with my Xbox itself. Postums told me via DM that he would be back in the office on Tuesday and would get with the dev team to try to resolve the issue. He is also the one who suggested I post it here. This is just really bad timing with the BTB tourney less than a month away. Hopefully 343 has a way to fix the issue, or at the very least makes a statement that they are working on it.
What type of internet do you guys have? I've heard of people who were on satellite connections and couldn't play Halo 5 because of the dedicated servers. Since MCC recently went from P2P to strictly dedicated except for customs, this looks like a problem with you guys not being able to play on dedicated servers with your ISP. If you have Halo 5, do you get an error saying something about not finding a suitable server to play on?
Check out CO2’s response first, but I thought I’d also mention something. Have you tried forwarding your ports? If not, that’s something you can try in addition to whatever else you have done to get an open NAT. There are some great guides on Reddit and Googling “port forward Xbox” or something similar can get you some good help. If your router gives your Xbox automatic “gaming rights”, override them by setting things up manually.
I have internet from Cox Cable. And it worked fine until January.
I forgot until I read tuhin's reply but yes we did try forwarding my ports. It worked for one game then went back to the same problems again.