Forums / Support / Halo 5: Guardians Support

[Locked] Constantly kicked at loading game 4/4

OP A0D NECKR0

So I've been playing since the game was released with no problems.
My connection is wired, my nat type is open. I live in the UK my ISP is virgin have the 100mb line with super hub3 router.
I have the following ports forwarded:
TCP: 80
UDP: 88, 500, 3544, 4500
TCP and UDP: 53, 3074, 3075

Recently when I've been trying to get into games (it happens 9 times out of 10) I've been getting returned back to the lobby with the following error
"Unable to join the game. join-in-progress encountered an issue".
This always happens when it gets to "loading game 4/4".
People in my party will see my emblem disappear then I'll get the error and be in a loading screen by myself. (https://xboxdvr.com/gamer/a0d-neckr0/video/68486859)

I've tried using an alternative Mac address as recommended by a friend but it's made no difference. I've also uninstalled and reinstalled the game and all data twice (digital copy).

Any ideas on what could be causing this or any fixes?
I have this issue once at the start of every "session" (i.e. group of matches), but not after that. Since you're saying this happens 9/10 times I assume you're having a different issue, so does this only happen when playing in a group or also when solo queuing?
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
I think this may be a separate issue since the two of you are most likely playing on the same internet connection. Two of the people I play with have the same issue as you and are on the same connection as well, but the rest of us make it into the match just fine.

I think some of the information in this thread may be of some help for your issue. It appears that perhaps certain types of routers can cause this problem, but you could also try messing around with your router and console settings.
DoubleSama wrote:
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
I think this may be a separate issue since the two of you are most likely playing on the same internet connection. Two of the people I play with have the same issue as you and are on the same connection as well, but the rest of us make it into the match just fine.

I think some of the information in this thread may be of some help for your issue. It appears that perhaps certain types of routers can cause this problem, but you could also try messing around with your router and console settings.
I have a hard time believing that the Halo 5 servers act up because they don't work well with certain types of routers/modems.

You're right, my fiance and I play on the same hard wired connection but it's only with Halo 5 that we run into issues. Overwatch, Fortnite, Gears of War 4, Black Ops 4, The Master Chief Collection, and Anthem (Beta) are the games we've played over the last few weeks and we have no trouble partying up. It's only when we play Halo 5 that it becomes an issue.

I appreciate the link to the old post. I'll take a look and see if anything has been updated as of recently. It seems that 343's last response in that post was also back in 2015. Surly there must be something a bit more recent.
DoubleSama wrote:
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
I think this may be a separate issue since the two of you are most likely playing on the same internet connection. Two of the people I play with have the same issue as you and are on the same connection as well, but the rest of us make it into the match just fine.

I think some of the information in this thread may be of some help for your issue. It appears that perhaps certain types of routers can cause this problem, but you could also try messing around with your router and console settings.
I have a hard time believing that the Halo 5 servers act up because they don't work well with certain types of routers/modems.

You're right, my fiance and I play on the same hard wired connection but it's only with Halo 5 that we run into issues. Overwatch, Fortnite, Gears of War 4, Black Ops 4, The Master Chief Collection, and Anthem (Beta) are the games we've played over the last few weeks and we have no trouble partying up. It's only when we play Halo 5 that it becomes an issue.

I appreciate the link to the old post. I'll take a look and see if anything has been updated as of recently. It seems that 343's last response in that post was also back in 2015. Surly there must be something a bit more recent.
Try changing the connection port in network setting, Default is 3074, change one console to a different port and you shouldn't have a problem.
Yeah if I were you I'd look into port forwarding the Xbox live to each of your xboxs. As A1tontoyato said you'll need to change one port in your network settings.
DoubleSama wrote:
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
I think this may be a separate issue since the two of you are most likely playing on the same internet connection. Two of the people I play with have the same issue as you and are on the same connection as well, but the rest of us make it into the match just fine.

I think some of the information in this thread may be of some help for your issue. It appears that perhaps certain types of routers can cause this problem, but you could also try messing around with your router and console settings.
I have a hard time believing that the Halo 5 servers act up because they don't work well with certain types of routers/modems.

You're right, my fiance and I play on the same hard wired connection but it's only with Halo 5 that we run into issues. Overwatch, Fortnite, Gears of War 4, Black Ops 4, The Master Chief Collection, and Anthem (Beta) are the games we've played over the last few weeks and we have no trouble partying up. It's only when we play Halo 5 that it becomes an issue.

I appreciate the link to the old post. I'll take a look and see if anything has been updated as of recently. It seems that 343's last response in that post was also back in 2015. Surly there must be something a bit more recent.
Try changing the connection port in network setting, Default is 3074, change one console to a different port and you shouldn't have a problem.
Odd but I'll give it a try
Actually I have this problem with Black Ops 4. Two Xboxes can't use the same port, which the default is 3074, and the other usually tries to use 3075. It also doesn't seem to matter as whichever Xbox gets the port first the first time you play together, it's like the system remembers that and will keep using the same port, so if your console got the 3075 when playing together it's almost like that one sticks from there on out. My girlfriend's One X would always get port 3074 even if my One X was in the game first and solo before hers even powered on, so I was stuck with random disconnects and stuff on 3075.

I've gotten it to work better by simply throwing a Static IP on my One X and putting that in the DMZ on my router. I never had this issue on Halo 5, but the circumstances are similar enough to what I've seen before.
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
This is still happening to me and I can't find an answer. I have been trying to party up for 2 days. Only happens in matchmaking, Campaign works fine online. But multiplayer Works fine with some people and not at all for others.
donrayna wrote:
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
This is still happening to me and I can't find an answer. I have been trying to party up for 2 days. Only happens in matchmaking, Campaign works fine online. But multiplayer Works fine with some people and not at all for others.
Came to find out that it was router setting that was causing the issue. Our router and security settings were set to strict which made it difficult for us play together. Look into what your current "NAT" is and if it's anything other than "open", look at changing the settings.
donrayna wrote:
I have this same issue! My fiance and I play on separate Xbox One X's when we play Halo 5. Separately, we have no problems playing in matchmaking but the moment we join up together and try searching, one of us will get the ""Unable to join the game. join-in-progress encountered an issue" and it's always happens when the game gets to the "loading game 4/4".

It's incredibly frustrating and I'd also like to know what the deal is so the two of us can start playing together again.
This is still happening to me and I can't find an answer. I have been trying to party up for 2 days. Only happens in matchmaking, Campaign works fine online. But multiplayer Works fine with some people and not at all for others.
Please don't revive old topics thanks