Skip to main content

Forums / Support / Halo 5: Guardians Support

Dedicated server issue with Series X

OP dobbser

  1. 1
  2. ...
  3. ...
  4. 2
Anyone else having issues getting a multiplayer game going? I’m unable to get one going. I get the “problem with the dedicated server” message. I’ve been playing on the Series X. Not sure if that has anything to do with it.
What game type you trying to play?
dobbser wrote:
Anyone else having issues getting a multiplayer game going? I’m unable to get one going. I get the “problem with the dedicated server” message. I’ve been playing on the Series X. Not sure if that has anything to do with it.
I don’t believe that’s a Series X issue. I played Halo 5 on mine last night without an issue.

”Problem with the dedicated server” messages are purely connection based issues. Xbox Live was facing issues last night due to everyone jumping online at once - may have something to do with that.

More than likely it’s just a case of whoever the game was trying to match you with the connections were not compatible.
ZAPDANGDO it was Solo/Duo Comp. seems to be working this morning.
im having the same problem with matches on xbox series x
Having the same issues. Happens on occasion.

Noticed Warzone also says I have a strict NAT type, which was definitely “Open” on my One S before I upgraded to the Series X yesterday. Using the same Ethernet cable that went into my One S, so no difference in connection.
Yes new x and s no luck but old s loads n works . This hasbeen down since 11am pst
Have 3 systems linkd only older version connects
Please update n fix
Ok i unplugged power cord from back waited a few minutes and 2nd attempt fixed it . Worked on x and s console. New post from previous
ok ive been doing hard reboots holding down the power button for 10 seconds and when it restarts it lets me get into a match
Reposting this:

My friends and I have found one (somewhat) consistent fix to for matchmaking party errors.
  1. Host starts a custom game.
  2. Other players join custom game.
  3. Host will join custom game.
  4. Other players will receive unable to join messages.
  5. Other players quit Halo.
  6. Host doesn't quit Halo.
  7. Other players start Halo.
  8. Other players rejoin host.
  9. Success.
343, I sincerely love your games and Halo 5. It's provided me with so many memories.

But we'd like some awareness of visibility from ya on this issue.
I've been having this problem for almost a week now. Takes me multiple attempts just to get into a match.
Also been getting a lot of dedicated server issues on series X, on the solo/duo queue
We unplugged Halo 5 and plugged it back in late last week. Have y'all noticed any improvements with things?
This seems to be an issue with quick resume. Any time I quite the game completely and restart the game match making works again.
We unplugged Halo 5 and plugged it back in late last week. Have y'all noticed any improvements with things?
I'm thinking it's a quick resume issue. Was playing fine last night, turn on the Xbox and it gives the issue right away today.
It's so annoying Halo5 Multiplayer show me error on Xbox Series X "Dedicated server not found" and then I have to switch back to my old Xbox just to play halo5. What's the point of upgrading a console when older console runs better than new one.
Been having the same issue and it’s the only game I enjoy most.. kinda frustrating that you can’t play your favourite game on the series x.. especially when your in the mood..
makes me want to play my ps5 more so than ever..
BMARRI wrote:
Been having the same issue and it’s the only game I enjoy most.. kinda frustrating that you can’t play your favourite game on the series x.. especially when your in the mood..
makes me want to play my ps5 more so than ever..
Try going to forge first to get the errors out of the way since Halo 5 uses dedicated servers for forge. Then multiplayer should work flawless. It seems to only happen when first starting up the game.
i got it to work somehow temporarily but it’s darn annoying because it’s not a one time fix.. I’ve had to do it multiple times.. it works but then goes back to giving the error.

unplugging it for 5mins and then trying it on again.
Basically a hard reset is what got it going
I’ve sort of fixed it. The thing I’ve been doing consistently now is once I get the “problem with dedicated server” issue, I immediately choose another game type (Team Arena, Slayer, etc). Once I’m in that queue I soon get a message that says I timed out. I clear the message and I’m still in the new queue/game type. This queue usually works and I can get into a game.
Not related to this topic, but I’m also getting my controller not connecting occasionally when powering on and the Series X powering back on immediately after I turn it off by controller. Microsoft is aware of these issues so I just wanted to let anyone else know so they can know that MS looking into it. The recommended remedy from MS is to hard reset by holding down the logo on the console for 10 seconds. It will work like normal after.
  1. 1
  2. ...
  3. ...
  4. 2