Skip to main content

Forums / Support / Halo 5: Guardians Support

Playing H5 on XsX has become unbearable.

OP Avionium

“Attention - there was a problem with the dedicated server”

I'm seeing this almost 50% of games I play. Quit game, quit application, try again - Does not remedy this.

I get kicked from parties, and my friends can’t join me. Not an issue in Xbone.

anyone have a solution that works?
No, unfortunately there isn't a real solution to that problem. I was banned 3 times so far for quitting a game while having a join request error or dedicated server issue with friends. I was literally banned because the game doesn't work and the match didn't start.

Even the things down below doesn't really help, only lucky tries.
- different search preferences: balanced/ expanded/ focused
- hard reset
- clearing mac address/ restart
- quitting all games/apps via guide button (quick resume feature)
- different startup modes
- checking UPnP / modem settings in general, rebooting

Playing H5 and looking for a working match is like playing russian roulette with 5 bullets in the chamber.
It's a real shame that the only exclusive game for xbox doesn't get a patch or upgrade.
Avionium wrote:
“Attention - there was a problem with the dedicated server”

I'm seeing this almost 50% of games I play. Quit game, quit application, try again - Does not remedy this.

I get kicked from parties, and my friends can’t join me. Not an issue in Xbone.

anyone have a solution that works?
ChaosRave has some good suggestions — though search preference shouldn’t make a difference.

What’s usually worked for me is to quit the game via the guide menu and to make sure the game reboots from scratch. That works 90% of the time. You can also delete game data. It’s most likely the quick-resume issue.
I thought Quick Resume might be the issue as a friend and I both get this about 50% of the time on our Series consoles.

While hard quitting the game helps, it certainly hasn't fixed the issue for me. I'm still about half the time sat waiting just to get the error message.
Avionium wrote:
“Attention - there was a problem with the dedicated server”

I'm seeing this almost 50% of games I play. Quit game, quit application, try again - Does not remedy this.

I get kicked from parties, and my friends can’t join me. Not an issue in Xbone.

anyone have a solution that works?
This happens to me often as well. I find it helpful to start every day with a solo custom game that I immediately end, and afterwards, my connection seems to get better.