Forums / Support / Halo Wars Series Support

Achievements Not Working

OP Ymmit 1222

  1. 1
  2. ...
  3. ...
  4. 2
I have found all the skulls and my Achievement has not come up as complete. Also there are about 6 other achievements that I have completed and yet nothing. please fix this
yes thank you i'm having trouble with mission 3 with the bridge i did it several ways like drop 5 units from bridge finished game it didn't give it to me and i started a new game and did several drops over 5 units in total. so quick recap i dropped 7 units on the bridge at the same time. try number 2 i tried over 5 with different units. i thought the achievement was drop 5 or more unit at the same time which i did and nothing happened. i wish there was a way to fix it and just give me the achievement.
Seems like there are issues across the board with the Achievements today: Related Forum Topic
i tried it with the person that made this post on co op game and it still didnt give it to me
Several of the achievements are broken, they have been since the release of the game. I've got three that won't unlock and it's been almost a week since I did them.
I've beaten the game heroic twice. All under par. Achievement hasn't popped.
I completed the campaign on Legendary, and none of the completion achievements unlocked. Is it because it is Early Release version??
No idea. Has happened to some others too. Frustrating.
same for me with the succès about timer in heroic and gold medals☹
Achievements not working for me are the mission specific ones as well.

some of them are popping on my phone, and the lifetime campaign score one has popped on the console - but when I go to the achievements menu via console it is still filtered with "locked"
can we have a fix about that?
You are playing in XBOX 360 or XBOX One, because on XBOX 360 it works.
Halo Historian for Unlock All Timeline Events hasn't worked for me, stuck at 97%. I used several guides to confirm, and even found a page that listed all of the time lines for the game which are all unlocked for me but I didn't get the achievement. :(
Last evening around 10:11PM EST (USA) I completed Mission 2 and did not receive the achievement for completing Mission 2 until a few minutes after finishing the mission and exiting the game. I did not wait more than 1 minute after completing the mission and before exiting the game. I'm running the current PC version, USA, gamertag: rhrmn, i5-6600 16GB DDR4 2133 and GTX 1060 6GB.
Same issue. Achievements I know for a fact I completed just aren't unlocking. Extremely frustrating considering I'd like to just complete the game and story achievements and move on to HW2.
Achievements not recording is currently a known issue, that is being looked at. I would suggest going for other achievements at the current moment
When im playing this on my XB1 the achievements pop when i get them but when i play this on my PC the achievements dont pop is there anything i can do?
yes Please fix this!
i currently have 1.2m campaign score and no achievement, i have played 29 hrs and dont have that achievement i had to play multiple skirmish achievements twice to unlock them like 2 bugs are better than one, and i have one atleast 1 skirmish game on every map and yet it only shows 88% complete. i have restarted halo wars multiple times aswell as the app and still no achievements!
I suppose this is the correct thread to post this. If there is a different thread that is for achievements not working, I can go there.

Yesterday, I completed mission 5 (Arcadia Outskirts) and I did not receive any achievements. I also collected the skull and black box, and I did not receive progress on those achievements based on my Xbox achievements section. (It still says I only have 4 of each -- I have gathered all from the first 5 missions, counting this last one.)
I actually completed mission 5 twice due to my missing a Wraith for the skull the first time. The achievement for completion did not pop either time.
I also am confident I hijacked at least 6 vehicles with Spartans during that mission for the "He's Got the Jack" achievement. This achievement did not pop either.

I checked this morning, and none of the achievements have popped still. No further progress of skulls/black boxes achievements have shown yet either.
If anyone has any information on this, it would be appreciated. Thank you.

EDIT: So, I hard reset my Xbox and my achievement are working again. I did need to replay the mission to get them though.
I just completed the game on Legendary difficulty and none of the achievements popped for me after.
  1. 1
  2. ...
  3. ...
  4. 2