Forums / Support / Halo Wars Series Support

Halo Wars 2 crash immediately on Win10

OP BloodReaver87

  1. 1
  2. ...
  3. 2
  4. 3
  5. ...
  6. 5
Hi everybody

I've try to play Halo Wars 2. But if I allways start the Campaign (the render video works fine) or start the turtorial, the game crashes to the desktop without an message.

I've a Core i7 6700k @ 4,5 Ghz, an GTX 1080 with the newest driver and 16 gb ram. OS is Windows 10 Pro.

Other win10 games works fine. For example gear of war 4.
When I click "Play" it opens a window and then closes immediately. :(
Works fine for me.

My PC specs are:
Intel Core i7-4700HQ CPU @ 2.40GHz
12 GB ram
Windows 10 (x64)
Intel HD Graphics 4600
NVIDIA GeForce GT 750M
I can not play it either. As soon as it loads a round it crashes...

My PC specs are:
Intel Core i7 6800K @ 3,8 GHz
Windows 10 Pro 64bit
im glad im not the only experiencing issues, I paid extra money for a sooner release date and i cant even play the game just like the beta,is there going to be a fix?
I'm also having this problem. Every time I open the game it crashed immediately.
Same here - I get the Halo Load Screen and it just crashes without an error.
Similar issue, played all the tutorials but just randomly will close out of the game. No errors or anything then I launch it and it stays in window mode, then I have to close and reopen it to go to full screen.
I found a semi solution to this. First I had to update all my drivers which allowed for a little bit more time before it crashed. I was able to play for about half a campaign mission then it would crash. I was recording with OBS studio at the time and when massive battles would occur or just a huge spike in the cpu the game would instantly crash at 100% cpu usage rather than just stutter. So i stopped recording and streaming and its fine now. So just keep a look on your cpu and close out any other programs.
I think before with another Xbox game of sorts that you should make sure Game DVR is disable/turned off.

Mine only seems to actually crash when I'm in options. Still annoying
Yeah, I'm getting a similar issue. I hit play, the screen pops up for a second, and then POOF I'm back at square one. I had issues installing it, too. Couldn't download it on my primary hard drive, so I had to put it on my secondary one. I might try re-downloading it in a bit to see if that fixes it.
I'm also having this problem, though mine is strange. I loaded the game the first time and it crashed in the options screen in the main menu (just as I started the game). Second time I play a whole match in multiplayer, all fixed right? Nope, it crashes soon after the game ends (also that match was extremely choppy). Third and final time I launch the game, I try to go back into matchmaking, it crashes as soon as all the players were found...
Please Halo, fix this problem. I want to play the game I bought, not just look at it in my library.
I think I have a semi-solution. Change from fullscreen to window mode, an then change from window mode back to fullscreen. Start a Mission. This solution works for me 80%. Just in Skrimish, it does not work.
i have the same problem, I read that 343 knows the issue but cant explain and is working on the issue. I think its a windows 10 issue because same issue happens when i would play Gears of war 4 on my computer.
as of right now this is not as stable game and need a lot of tweaking. I wish the developers did this before they released the game.
Im having the same issue on windows 10 Pc. 2/21/2017 As soon as i get the game going when i go to options about 5 seconds after it freezes then crashes. As if i exited the game. Havent been able to play it yet. This is unfortunate :( . Is there anywhere we can report this issue? Or do they know about it. I could download it on my xbox one. But id really rather play with a mouse and keyboard on this type of game.
I made a thread about this sort of issue that you can find at

Short version:
For Nvidia GPUs, try going back a few driver versions. Here is the download link (direct from Nvidia) for the one I am using that has worked so far.
Im having the same issue. If i start the campaign or the tutorioal i can play 1 or 2 minutes and the game crashes without message. I tried a few drivers for my gtx 1080 but on each driver i have the same problem.

I tried to run my overclocked i7 6700k on stock but also that did not help.
Having the same issue. Get through the cutscenes fine, but then when it tries to start up gameplay, the whole thing crashes out.
Core i7 6700k @ 4GHZ
windows 10 x64
nvidia GTX 970 FTW+ running slightly overclocked

I had this issue during the beta, and I was hoping that it would be fixed by the time that the main game came around. So far leaving a sour taste in terms of future play anywhere titles.

Tried rolling back drivers to the ones suggested above, and nothing. Tried restarting, underclocking, overclocking, standard clock, not having programs open, restarting, running in windowed mode, running in small window. You know, just about everything I can think of. No fix. Anybody else get it working?
having the same problem I have a i7 2600k gtx 980ti 10 gigs of ram

Quality control is really bad 343 have no idea to make a game at all
  1. 1
  2. ...
  3. 2
  4. 3
  5. ...
  6. 5