Forums / Games / Halo: The Master Chief Collection (PC)

Halo MCC: Offline / Unavailable Cannot Launch Game

OP CluckerByte

Hello, this has been an issue now since the previous patch, and I've seen people floating around the web with the same issue but nobody is really talking about it or shedding any light, including the developers who I sent a ticket to about this issue about 2 weeks ago.

Sometime after the latest patch the game just stopped working for me and wouldn't open, presenting me with an error that Halo MCC is offline and / or unavailable (the error was longer)

This happens even if I uninstall and re-install the game.

To resolve the issue temporarily, I need to uninstall Halo MCC, remove all traces in appdata and program files, uninstall the cheat detection software in program files and delete all the cached data from the download (so it downloads fresh) from my drive and then reinstall the game fresh from WIndows Store. I have my windows apps / games installed on my secondary drive. I can open and close the game as many times as I wish before rebooting my PC. The moment I reboot my PC the game goes into a "repair state" in the Windows Store, and fails to run giving me the Offline / Unavailable error again.

Installing Windows 10 Pro fresh w/ drivers and latest updates doesn't do anything to help and the issue remains. I've also replaced my primary and secondary drives to be doubly sure.

Troubling issue, Microsoft rejected my request for a refund regardless of the fact that at some point they've broken the game on me that worked upon initial purchase, and I'm keeping my fingers crossed that the next patch kicks something back into gear that broke in what I believe to be the last patch, so I can play properly without having the annihilate the game from my system after each reboot and re-download 40GB again..

Has anybody else encountered this issue? If so has anybody resolved it? Any ideas?

Given this is happening on a brand new fresh install, it seems to me likely that it's the game, just bizzare that I'm having the issue and most others are not, which further isolates it to perhaps a compability issue with my particular setup that the previous patch introduced?

4790k
RTX 2080 SUPER
16GB DDR3 RAM
1x 128GB SSD (Windows)
1x 512GB SSD (Games)