Search

Forums


  1. Yea dude I think they forgot to add the new reqs into the packs Guess we'll have to wait for them to realize it.