Search

  1. 1
  2. ...
  3. 2
  4. 3
  5. 4
  6. 5
  7. ...

Forums


  1. Loving the MCC update, 60Hz does feel smoother for me. However, still having the same issue: Games: All/Multiplayer Issue: Every single game is on US West when I'm in Australia (East Coast). Also each game has at least 2-4 Aussies in it (I...

  2. To those who felt Halo 3 was "off" due to its spotty hitbox, what do you think of the new update? Because I've just finished playing a bunch of games, and I have to say that H3 has never felt so good as it did right now. I could finally...

  3. Yeah, same for me: I often get matched to US servers, in particular the East one, where I have a ping of 120, give or take. I've always suspected this was the case and it's nice to finally receive a direct confirmation from the loading screens...

  4. To those who felt Halo 3 was "off" due to its spotty hitbox, what do you think of the new update? Because I've just finished playing a bunch of games, and I have to say that H3 has never felt so good as it did right now. I could finally...

  5. MCC HALO GAME: Halo 3 ISSUE/FEEDBACK: Hit registration, expecially for the Battle Rifle, needs to be fixed. I'm currently pinging 4 ms from MS servers (and like 18 ms from the EU MCC server) and I have an average download speed of 100 Mbps. Still...

  6. MCC HALO GAME: Halo 3 ISSUE/FEEDBACK: Hit registration, expecially for the Battle Rifle, needs to be fixed. I'm currently pinging 4 ms from MS servers (and like 18 ms from the EU MCC server) and I have an average download speed of 100 Mbps. Still...

  7. MCC HALO GAME: Halo 3 ISSUE/FEEDBACK: Hit registration, expecially for the Battle Rifle, needs to be fixed. I'm currently pinging 4 ms from MS servers (and like 18 ms from the EU MCC server) and I have an average download speed of 100 Mbps. Still...

  8. ISSUE/FEEDBACK: The UI label on the upper left of the screen is bugged when you choose Campaign or Multiplayer from the Main Menu. It should show the option you just selected, instead it only says "MAIN MENU", as you can see here...

  9. H3 is finally working for me with the latest build. No more corruption issues! Spoke too soon... sadly my portion of H2A MP is corrupted (H2 Classic works fine though). I've got the feeling that Phase 2 will be once again delayed... Last update since...

  10. H3 is finally working for me with the latest build. No more corruption issues! Spoke too soon... sadly my portion of H2A MP is corrupted (H2 Classic works fine though). I've got the feeling that Phase 2 will be once again delayed...

  1. 1
  2. ...
  3. 2
  4. 3
  5. 4
  6. 5
  7. ...